Importing SVGs to Lucidchart OnPrem for Confluence Server

If you are running Confluence 5.x, you may run into an issue where SVG import fails and it asks you to install another add-on. This occurs because Confluence 5.x only partially includes certain functionality that SVG import needs to work. To resolve this, you can either upgrade to Confluence 6.x, which supports SVG import, or install an additional add-on.

Before you install the add-on, please make sure each file you selected has .svg at the end of the filename. Additionally, double check that you're on Lucidchart's Confluence OnPrem connector version 1.16.7 or newer. Then, to install the add-on, follow these steps:

  1. Download the importer add-on. Once you have downloaded the ZIP file, please extract the files (depending on your operating system, right-click > Extract All or double-click the file) and then upload the OBR file in the unzipped/extracted folder to Confluence.
  2. Upload the add-on to your Confluence instance.
    • As an admin, open the Confluence administration menu and select "Add-ons."
    • Select "Manage Add-ons" in the left panel.
    • Click "Upload Add-on" and then select the file you downloaded in step #1. The add-on will be uploaded and automatically installed.
  3. Reinstall Lucidchart Diagrams OnPrem for Confluence.
  4. You're done. SVG import works!

NOTE: If you upgrade Confluence to 6.x, uninstall the importer add-on as it is no longer needed.